freeSSHd and freeFTPd

Remember me Registration (Optional)

Please note that there is no official support from the author for freeSSHd or freeFTPd. You should not expect to receive response on messages posted here.

Forums -> freeSSHd - General -> Error : The specified address is already in use
Reply | New topic

Antoine
Newcomer
          
question.gif Error : The specified address is already in use 23-01-2006 18:49
hi,
I am trying to install a SSH server on our Windows 2003 Server, wich is our domain controler. I tried several free product, but it is difficult to find one wich is working. So I saw this one FreeSSHd.
Installation without any problem, Telnet server fine. But when I try to run the SSH server, I have this message "The specified address is already in use". As the server has several network card, because of several sub networks, I tried all the adresses I have, but always the same message.
I saw that another person had the same problem in the forum, but no answer in this post. But perhaps today someone has the solution for this annoying problem ?
Thank you
Antoine

____________________________________
Saginaw crossover

Reply with quote

freesshd
Your main contact

Postings: 936
Administrator
          
Re: Error : The specified address is already in us 29-01-2006 15:50
Ok, try this.

Open up Command Prompt and type in "netstat -anb".
You'll see a table of connections and opened ports on your computer, and name of program involved in creating each connection. Try to find a table entry that looks something like "TCP 0.0.0.0:22". There will be a name of a program next to it. That program occupied this port and freeSSHd is unable to use it. To release the port, just close that program and then try to run freeSSHd again.

Regards
Reply with quote

Twilight
Anonymous
          
Re: Error : The specified address is already in us 17-03-2006 20:04
I had a similar problem as well. After using the product for a while without problems, suddenly it stopped working and sent me tthe same error message "... already in use"

With the help of a couple neat little utilities (Active Ports and Procexp) here is what I found:

1. No program was using port 22, it was free
2. There was a CMD.exe running (in the background, apparently) which was I think was started by freesshd.
3. Killing this cmd.exe I was able to start freesshd without a problem...

In case you're interested, freesshd, I since then I have found that this problem is quite easily reproduced. Just do the following:

1. Start your SSH server
2. Open a SSH session using Putty
3. Close the Putty window by clicking on the x button on the top right corner.
4. From the freesshd control console, stop the SSH server and try to start it again... Voila... I can't

Now, using the Active Ports utility, it shows that no one is using port 22, but fresshd still gives the same error message "ERROR: The specified address is already in use.

Using the Process Explorer utility I find an "orphaned" cmd.exe session which I recognize as having something to do with my putty/freesshd session, because it has my SSH user's directory open...

After I kill this process with the Process Explorer I can restart the ssh server without a problem...

Also, I've noticed that Putty/FreeSSHd sessions create two cmd.exe processes. When you close your session using the "exit" command, both of these cmd.exe programs get closed, but if you close your session by clicking on the x button, only one of the cmd.exe programs gets closed, the other one is still there...

I hope this info will help...

By the way, awesome product!!! I like it very much. Maybe later with a little more time in my hands I can comment on some changes I'd like to see! Thank you!!!

Best Regards

Reply with quote

Twilight
Anonymous
          
doh.gif Re: Error : The specified address is already in us 17-03-2006 20:07
Sorry for the typos. I think I was writing too fast for my brain to catch up... heheh
Reply with quote

freesshd

Administrator
          
Re: Error : The specified address is already in us 19-03-2006 23:09
Twilight, I'll try it. I tried it on XP system, it works as expected. I just need to try it on Win2k3 too.
Reply with quote

Twilight

Anonymous
          
Re: Error : The specified address is already in us 25-03-2006 20:37
Quote:
Twilight, I'll try it. I tried it on XP system, it works as expected. I just need to try it on Win2k3 too.


My personal experience was on a W2K machine. Haven't tried it on XP yet...
Reply with quote
 

Search the forum

Latest posts

Current version

Related sites

Internet & Security Components

VPN and Instant Messaging - all in one!